Installation and Configuration FAQs

Top  Previous  Next

 

Q. Can I run Clarion and Clarion.NET on Windows 7 (64bit) or Vista (64bit)?

Yes, no problems at all.

 

Q. Is .NET 3.5 and ASP.NET 3.5 supported under Clarion.NET?

 

A. Yes they are, and Ajax 3.x is also supported.

ASP.NET 3.0 and ASP.NET 3.5 are additive releases, meaning that the core assemblies have remained unchanged since ASP.NET 2.0.The underlying runtime hasn't changed, it's still CLR v2.0 and even C#3 still compiles to 2.0 MSIL which is executed on the 2.0 CLR.

ASP.NET 3.5 doesn't change or take away or break any functionality, or code present in 2.0. The move to ASP.NET 3.5 is quite gradual, it uses the same engine as that of ASP.NET 2.0. with just some extra features added on top of it.

The .NET Framework 3.0 is an additive release to the .NET Framework 2.0 and adds four new technologies to .NET 2.0:

Windows Presentation Foundation (WPF), Windows Workflow Foundation (WF), Windows Communication Foundation (WCF), and Windows CardSpace.

There are no changes to the version of the .NET Framework 2.0 components included in the .NET Framework 3.x And .NET 3.5 is also an additive framework update, not a replacement. You will still be using v2.0 portions of the BCL and FCL at the same time as using 3.0 and 3.5.